/ / kleine Version von minsdkversion? wie kann ich es reparieren ? - Android, apk, unterzeichnet

kleine Version von minsdkversion? wie kann ich es reparieren ? - Android, apk, unterzeichnet

Dies ist mein Code und es heißt, dass der Fehler ist, ich habe eine kleine Version von minsdkversion verwendet? wie kann ich es reparieren ?

apply plugin: "com.android.application"

android {
compileSdkVersion 23
buildToolsVersion "27.0.3"

defaultConfig {
applicationId "com.ismailtaibi.ismagame.spidermanjamp"
minSdkVersion 11
targetSdkVersion 23

ndk {
moduleName "player_shared"
}
}

buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile("proguard-android.txt"), "proguard-rules.txt"
}
}
}

dependencies {
compile "com.google.android.gms:play-services:+"
compile files("libs/dagger-1.2.2.jar")
compile files("libs/javax.inject-1.jar")
compile files("libs/nineoldandroids-2.4.0.jar")
compile files("libs/support-v4-19.0.1.jar")
}

und das ist der Fehler

Fehler: C:UsersismaprodStudioProjectsandroid3appsrcmainAndroidManifest.xml: 7: 5-73 Fehler: uses-sdk: minSdkVersion 11 darf nicht kleiner als Version 14 sein, die in der Bibliothek [com.google.android.gms: play-services: 11.0.4] deklariert wurde. C: Usersismaprod.gradlecachetransforms-1files-1.1play-services-11.0.4.aar

  • Was schief gelaufen ist: Ausführung fehlgeschlagen für Task ": app: processDebugManifest".

    Manifestzusammenführung fehlgeschlagen: uses-sdk:minSdkVersion 11 kann nicht kleiner als Version 14 sein, die in der Bibliothek [com.google.android.gms: play-services: 11.0.4] deklariert wurde. C: usersismaprod.gradlecachetransforms-1files-1.1play-services-11.0.4.aar

  • Versuchen: Führen Sie die Option --stacktrace aus, um den Stack-Trace abzurufen. Führen Sie die Option --info oder --debug aus, um mehr Protokollausgaben zu erhalten. Führen Sie mit --scan aus, um vollständige Einblicke zu erhalten.

  • Holen Sie sich mehr Hilfe bei https://help.gradle.org BUILD FAILED in 7s

Antworten:

1 für die Antwort № 1

In Ihren Abhängigkeiten haben Sie

compile "com.google.android.gms:play-services:+"

Diese Abhängigkeit benötigt das Android SDK 14 oder höher. Um dies zu beheben, ändern Sie Ihre Android SDK-Version auf 14:

minSdkVersion 14

Bearbeiten: Setzen Sie die SDK-Version auf den gleichen Wert wie die Build-Tools-Version kompilieren:

compileSdkVersion 27
buildToolsVersion "27.0.3"