/ / Fehler beim Ausführen von Pax Web Jetty - osgi, equinox, pax-web

Fehler beim Ausführen von Pax Web Jetty - osgi, equinox, pax-web

Ich betreibe Pax-Web in Equinox (org.eclipse.osgi_3.5.0 Bundle).

Ich betreibe Pax-Web-Jetty-Bundle_3.0.2 Bundle

Beim Start dieses Stegbündels (Pax Web Jetty) tritt folgender Fehler auf:

The bundle could not be resolved. Reason: Missing Constraint: Import-Package: org.osgi.framework.wiring; version="[1.0.0,2.0.0)"

Ich kann nicht finden, welches Paket das Paket org.osgi.framework.wiring bereitstellt (exportiert). org.eclipse.osgi ist nicht.

Vielen Dank.

Antworten:

2 für die Antwort № 1

Dieses Paket ist seit OSGi 4 verfügbar.3 (so viel ich mich erinnere) im OSGi-Kern. Sie verwenden eine zu alte Version von equinox, die diese Version von OSGi spec nicht unterstützt. Verwenden Sie Tagundnachtgleiche 3.7.1 oder neuer und das Paket wird dort sicher sein.