/ / Ungültiges CSS nach "... ules: $ modules": erwartet "}", war "! Global;") - zub-foundation, compass-sass

Ungültiges CSS nach "... ules: $ modules": erwartet "}", war "! Global;") - zub-foundation, compass-sass

Ich versuche alle Javascript-Bibliotheken eines Projekts, das ich vor Jahren von einem Provider bekommen habe, zu aktualisieren. Ich war in der Lage, fast alle erfolgreich zu upgraden, aber die Gründung.

In der Arbeitsversion ist die Foundation 5.4.7 installiert.

Also upgrade ich es mit

 bower install foundation

Wie ich alle meine anderen Bibliotheken installiert habe

wenn ich dann versuche es mit zu kompilieren

bundle exec compass compile

Ich bekomme den Fehler

error webapp/static/webapp/sass/app.scss
(Line 14 of webapp/static/libs/foundation/scss/foundation/_functions.scss:
Invalid CSS after "...ules: $modules ": expected "}", was "!global;")
overwrite webapp/static/webapp/css/app.css

error webapp/static/webapp/sass/stundenplan.scss
(Line 14 of webapp/static/libs/foundation/scss/foundation/_functions.scss:
Invalid CSS after "...ules: $modules ": expected "}", was "!global;")
overwrite webapp/static/webapp/css/stundenplan.css

Ich betreibe eine Windwos Maschine mit

  • Rubin 2.3.3p222
  • Knoten 6.7.0
  • Kompass 1.0.3 (Polaris)
  • Schienen 5.0.1
  • Gründung (1.0.4)
  • Fundamentschienen (6.3.0.0)
  • Sass (3.4.23, 3.2.19)
  • Sass-Schienen (5.0.6)
  • Bundler (1.14.2, 1.13.7)

Jede Hilfe wird geschätzt! Vielen Dank

Antworten:

0 für die Antwort № 1

Nun, ich werde hier meine Lösung posten. Zuerst habe ich meine alten Versionen der Edelsteine ​​entfernt

gem uninstall sass --version 3.2.19
gem uninstall bundler --version 1.13.7
gem uninstall compass --version 0.12.6

Und dann der entscheidende Teil: Wechseln Sie zu dem Anwendungspfad, und löschen Sie die Gemfile.lock-Datei dann ausgeführt a

bundler update

und jetzt mein

 bundle exec compass compile

funktioniert ... es gibt ein paar Warnungen, die ich lok an ... aber es funktioniert im Allgemeinen